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Screen Layout 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Mouse and Keyboard Controls 

 

Hot Keys 

Isometric View: END  

Snap to Nearest Orthographic View: F8 

Snap to Selected Datum or Surface: Left Click Datum or Surface to View > Select F8 

Fit to Window: Control (CTRL) + F 

Refresh: F5 

Background Colors 

 Select View Tab > Select Background Setup 

 



 

1. Select New from Home Tab 

 
2. New Pop-Up Menu will appear.  The pop up menu is setup to choose various types of project files (i.e. solid model, 

layout, assembly, machining/manufacturing, etc.) 

 

3. Select Model Tab > Select Model Tab > Select Model Template (This setup the work environment) > Change Units to 

Inches > Change File Name to Extrude Tutorial.prt > Select Folder > Navigate to Student Directory to Save work 

(Recommended to create NX Folder in Student directory) > Select OK 

 

 

 
 

 

 

Project File Types 

Units: Inches 
Select Model Template 

File Name: Extrude Tutorial 

File saving Location: Student Directory > Folder NX 



 

4. Workspace 

 

a. Resource Bar: Each Option will Change the Model Tree to Show Selected Resource 

 
 

 

 

 

 

 

 

 

 

Modeling Area 

Tool Tabs 

Model Tree 

Resource Bar 

Assembly Navigator: Shows All Models within an Assembly 

Part Navigator: Shows all Features that make up a Solid Model 

Part 

Internet Navigator: Opens Internet Web Browser Window  

History: Shows Files History  

Roles Navigators: Sets Up Design Team Roles for a Project   

View Plane Selection 

Datum Planes: Default 

Front View = XZ 

Right Side View = YZ 

Top View = XY  



 

b. Model Tree: Part Navigator 

                          
 

5. Model: Single Extrude 

Two Options for creating an extruded feature 

Option 1 External Sketch: This is where the user creates an independent sketch separate from the extrude.  

Typically used when the sketch maybe used multiple times with mutliple 3D features 

 

Steps:  Select Home Tab > Select Sketch > Select Datum Plane or Surface to Draw On > Draw Closed Profile 

Sketch and Set Dimensional Values > Accept Sketch > Select Extrude Icon > Set Extrude Dimensions > Except 

Extrude Feature 

 

Option 2 Internal Sketch: This will embed the sketch as part of the extrude feature.  This is used to help to 

minmize the length of the model tree and keep associated 2D and 3D features that are dependent on each  

other grouped together 

 

Steps: Select Extrude Icon > Select Datum or surface to Sketch On > Draw Closed Profile Sketch > and Set 

Dimensional Values > Accept Sketch > Set Extrude Demensions > Except Extrude 

 

 

 

Model Features 

Modeled Features/Parts being 

reference off of other models 

Parameter Settings set with Values. Used when a 

variable is set for a dimensional value that is 

altered based on environmental changes 

Preview of Design 

Saved Views 

 



 

a. L-Block feature (Internal Sketch) 

i. Select Extrude Icon  > Pop-Up Menu will Appear 

 

 

 
 

 

 

     

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Sketch Menu: Allows the user to 

Select a pre-created sketch or embed 

a sketch by selecting a Datum or 

Surface to Draw on 

Extrude Options: Extrude with Start Distance  

Start: Offsets Sketch from Selected Datum or Surface  

 - Start Value = 1” 

 - End Value = 2” 

 - Total Solid Material =1” (1” Sketch Offset from Start – 2” End Distance) 

 

Limits: Sets Dimensional 

Values of the 3D Shape 

Start: Sets Offset Distance 

from Sketch and Selected 

Surface (See Below) 

 

End: Sets Total Extrude 

Distance of Sketch from 

Selected Datum or Surface 

(NOTE: IF Start Value is set 

to anything else, but 0 the 

extrude amount of solid 

material that will appear 

will be Start Distance – End 

Distance (See Below) 

Extrude Options 

 

Direction: Allows User to Set 

Direction of 3D Feature based on 

its start point (Default is Normal to 

Selected Datum>Face) 



 

 

b. Select XZ Datum (Front View) > Work Space will Rotate Normal (Perpendicular) to Viewer 

 
NOTE: If view is rotated out of orthographic view (2D) > Press F8 or Selected face on View Rotator (bottom left 

corner of workspace) to rotate back to 2D 

 

NOTE: Default Profile is active by default.  This a poly line tool, meaning user will need to create a closed 

profile before the tool will stop drawing lines. Press Escape or Select another tool to deactivate  

 

 

c. Draw the following Rectangle Profile 

Dimensions Setting 

Option 1: Set Dimension in the Tool Dialogue Box 

i.e.  

 

Option 2: Set Rectangle then Change Weak Dimensions 

          
 

 

Feature Dialogue Box. Press Tab to switch between Settings > 

Left Click or Enter to Place    

Set Sketch Outline 
Double Click on Dimensions > 

Change Value > Press Enter 
Profile will Re-Size 



 

Final Size 

 

 
NOTE: Dimensions can be moved by placing cursor on Dimension > Hold Left Mouse Key Down > Drag Cursor to 

desired Location 

NOTE To Hide Axis and Datum Planes: Press CTRL-W > Show and Hide Pop-Up Menu will Appear > Press the Eye Ball to Hide or 

Show desired feature 

                      

 

 

 

 

 

 

 

 



d. Turn On Rapid Dimensioning if not on the Tool Bar 

i. In the Search Menu Type “Rapid Dimension” > Press Enter (NOTE: DO NOT Click on the predicted 

search results) > Select the Eyeball to Add Rapid Dimension Icon to the Toolbar 

ii.  

e. Draw the following lines > Set Dimensions as shown using Rapid Dimension Tool  

NOTE: To place Dimensions p9 and p10 Select the two parallel lines the dimension is measuring between 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select Eyeball 

Type Rapid Dimension in Search Menu > Press Enter 



f. Trim: Select Trim Tool 

Two Options to use this tool 

i. Option 1: Select each Line to trim separately by left clicking on the line 

ii. Option 2: Place cursor off the part but close the set of lines to trim > Hold Left Mouse Key Down > Drag 

Cursor through the lines to be trimmed > Let go of Left Mouse Key when Complete. 

 

 

NOTE: there is a second way to set dimensions:  

iii. With no tools selected > Click on the Edge(s) to Dimension > Dimension will Appear Green > Left Click 

on the Dimension Value to Place 

iv. Example Part Single Line 

 

 

 

Start Point 

End Point 

With NO tools Selected > 

Select Edge(s) > Green 

Dimension will Appear 

Place Cursor on Green 

Dimension> Dimension will turn 

Red 

Left Click to Place 

Dimension 



 

 

Example Parallel Lines 

 

 

g. Select the Finish Icon on Sketch Toolbar .  This will accept the sketch. 

NOTE: If Profile is not complete NX will turn the model into a Surface model, showing just the outline of the 

profile as a thickened line.  

 

h. Change End Value Distance to 3 > Select Ok 

NOTICE: The Strong Dimensions Visible on the part > User can double click on the values and change them from 

the preview 

 

With NO tools Selected > 

Select Edge(s) > Green 

Dimension will Appear 

Place Cursor on Green 

Dimension> Dimension will turn 

Red 

Left Click to Place 

Dimension 



 

i. Rename Extrude: Select Extrude (1) from Model Tree > Select Rename > Change name to L-Block Profile 

 

 

 

j. Edit Extrude and/or Sketch 

i. Edit Extrude: Double Click on the Extrude Feature in the Model Tree > Extrude Properties Menu will 

Appear > Adjust Values > Select Ok to Accept 

ii. Edit Sketch: Three Options 

1. Option 1: Double Click on Extrude Feature > Extrude Properties Menu will with Sketch 

Dimensions > Double Click on Dimension to Change > Press Enter to Accept > Select Ok in 

Extrude Properties to complete 

 

                     

 

 

NOTE: When Editing the Extrude the Sketch may become detached from the Extrude, this happens when the user selects in 

space making the software think the user is selecting another profile to extrude. To Correct Select an edge of the profile to 

reconnect 

 

 

 

 

Extrude Properties Menu 

Double Click on Feature in Model 

Tree 

Double Click on Dimension Value Change Value > Press Enter 



2. Option 2: Double Click on Extrude Feature > Extrude Properties Menu will with Sketch 

Dimensions > Select sketch Icon > Edit Sketch > Select Finish Icon > Select Ok in Extrude 

Properties to complete 

 

                                                 
 

 

 

 

 

 

 

3. Option 3: Select Extrude Feature From Model Tree (Left Click Once) > Right Mouse Button > 

Select Edit Sketch 

                                                      
 

 

 

 

 

 

 

 

 

 

 

 

 

Extrude Properties Menu 

Double Click on Feature in Model 

Tree 

Select Sketch Icon 

Edit Sketch > Select Finish Icon when Edits are Completed 

Select Feature in Model Tree 

Select Edit Sketch 

Edit Sketch > Select Finish when Complete 



iii. Using one of the methods above > Edit the Sketch to the Following 

 

 

 

 

6. Add/Remove Material 

a. Top Cut 

i. Select Home Tab 

ii. Select the Extrude Icon 

iii. Select the Face Shown 

 

Notice: Object becomes Transparent when selecting. This allows the user to see all of edges of a part 

 



 

 

iv. Draw the Following Rectangle Profile and Set Dimensional Values > Select Finish Icon when Complete 

                                 
Notice NX allows the user to snap to existing edges.  NOTE: Edges DO NOT need to be at the same 

plane as the sketch to snap too 

For Example 

 

                                        
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Selected Surface 

Selected Edge 
Sketch Face and Selected Edge 

Reference is projected back to Sketch Surface 



 

v. Extrusion Settings 

1. Select Reverse Direction in the Direction Tab  

Notice: the body automatically switches the extrude from adding material to subtracting 

material.  This is due to the Boolean Setting is set to Inferred.  If a user wanted to add material 

in this direction then the Boolean would need to be changed to Added 

 

                                                               
 

 

 

 

 

 

 

 

 

 

 

a. Cube Add 

b. Arc on Back 

2. Extrude Distance 1.00 > Select OK 

  

Part Will Look as Follows 

 

 

 

 

Select Reverse Direction 

Boolean: Allows user to let the 

software to decide on adding/subtract 

material based on location or set by 

user 

 

Option set to Inferred 

or Subtract 

Example of Boolean set to Unite (Adding) thru material 

 



vi. Change Extrude(2) Name to Top Cut 

 

 

vii. Modify Sketch to the following 

 
viii. Modify Extrude Distance to .500 

ix. Part Will Look as Follows 

 
 

 

 

 

 

 

 



 

7. Add the Following 2 Features >  

1. Cube Extrude 

 
 

 

2. Triangle Cut 

 

 



 

3. Rename Features in Model Tree 

 

 
 

8. Holes  

 

a. Hole Tool: Simple 

i. Select the Hole Tool  

ii. Hole Tool Menu 

 

Hole Types 

 

Hole Size 

Hole Location 

Set Direction Hole to Cut In 

Normal = 90 Degrees 

 

Depth of Hole Settings and Drill 

Bit Clearance Settings 



 

iii. Select the following surface 

 

      
 

iv. Sketch View will open.  User will set Center Points for 1 or more holes > Set the following 2 holes > 

Select Finish Icon to Exit Sketch 

NOTE: Select Point Icon and Place Point on Surface > Set Locator Dimensions 

  

 

 

 

 

 

 

 

 

 

 



 

v. Set Hole Type to Counterbore > Set the Following Dimensions > Select OK when Complete 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

vi. Drill the following simple hole with the settings shown 

 

 
 

b. Arcs 

i. Select Extrude Tool > Select the Bottom Surface of the Block 

 
 

 

 

 

 

 

 



 

 

ii. NX Requires the user to reference existing edges by drawing constructions lines on the edges or 

projected lines 

1. More Drop Down Menu > Select Project Curve 

  

2. Select the Edges as Shown  (NOTE Blue Lines are Projected) 

 
 

3. Select the Projected Edges > Select Convert To/From Reference 

a. Option 1: Right Click Select Convert To/From Reference 

 
 

 

 



b. Option 2: Add Tool Icon to Tool bar 

 

Final Construction Lines 

 

 

 

iii. Draw a circle on the line edge shown  

NOTE: Distance does not matter, a tangent constraint will be used to lock distance into place 

 
 

 

 

 



 

NOTE: Constraint Tools found at the Top of the Workspace when there are not any tools selected 

 

 
 

 

 

                             

1. Select MidPoint Icon  > Select Select Edge Edge of Circle > Select Construction Line> Press 

Apply 

                                                                                                        

 

 

 

 

 

 

 

 

 

 

Select 2nd Feature Option First > 

Then Select Edge > Press Apply 

To Lock the Circle in place 

Constraint Bar (Tools Left to Right) 

1. Coincident 

2. Collinear 

3. Horizontal 

4. Vertical 

5. Tangent 

6. Parallel 

7. Perpendicular 

8. Equal Length 

9. Symmetrical 

10. Mid-Point 

11.  

 

Select Circle 1st 



 

 

2. Select Tangent Icon  > 1st Select Circle > Select 2nd Feature Selection > Select Horizontal 

edge of part 

            

 

 

 

 
3. Select Finish Icon 

 

 

 

 

 

 

 

 

 

 

 

Select 2nd Feature > 

Select Construction Edge 

Select Tangent Tool > Select Circle 



 

4. Extrude Distance 1” 

NOTE: The software set to “Inferred” which means the default state will make the feature cut 

into the part > Change the Boolean to Unite to make the feature merged with the part > Select 

OK to Accept Extrude 

 

 
5. Model Tree > Rename Feature Back Arc 

6. Notice the Side Hole is filled in 

 

 

a. 2 Options to Fix  

i. Option 1: Reorder the Model Tree: Place Cursor on Back Arc on Model Tree > 

Hold Left Mouse Key down > Drag Feature above Dia. .50 Hole 

 

 

 

 

 

 

Filled In Hole 

                                  

Before After 



 

 

ii. Option 2: Edit Sketch Turning the Circle into an arc 

 
c. Fillets and Rounds 

i. Select Edge Blend Tool   (Edge Blend will Create Fillets and Rounds) 

 
 

ii. Select the following Edges> Select OK 

 

 
 

 

Draw a Line along the edge of the 

part > Trim away the part of the 

circle on the inside of the part 

Selected Edge(s) 

Arc Shape (Circular or Conic) 

Arc Radius 



 

 

 

d. Chamfer 

i. Select Home Tab > Select Chamfer Tool  

 

 
 

ii. Select the Following Edge 

 
iii. Select Ok 

 

Final Part 

 

 

 



 

Optional: Change Part Color 

i. Select View Tab > Select Edit Object Display  

 

 
 

ii. Class Selection Menu Appears 

1. Select Part(s) > Select Ok 

 
2. Select Part Color to Change to > Select Apply When Complete 

NOTE: Menu maybe used to alter many other features colors, line types, line weight, etc. 

                                                

 

 

 

Select Edit Object Display 

Part Color 

 


