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Frames Overview 

Allows the user to set an origin point within a 3-Dimensional Cartesian Coordinate System for Linear Axis X, Y and Z, along 

with Rotational Axis Awl (W), Pitch (P), Roll (R) on the robot, workpiece, workcell, tool, etc. Cartesian System sets three 

planes at Right Angles to each other (XY, XZ, YZ), these planes are called frames, allowing for easier navigation within 

programs by adjusting the frame type instead of modifying all points.   

                                                                                          

 

 

Working in Frames 

- When no data is defined Tool Frame is the Center of the Faceplate 

- Tool Frame data is a physical measurement from the tip of the end effector to the tip center plate 

- Tool Frame is commonly referred to Tool Center Point (TCP) 

- Controller types have a limited number of Frames 

o R30IB = 29 Frames 

o R30IB Plus (Current model at Brighton High School) = 253 Frames 

- When Selecting Jog Method Tool the active TCP becomes the focal point while jogging/moving the robot 

NOTE: Checking active Tool Setting: Press Select + COORD Key 

Positional Data (X,Y,Z,W,P,R) is dependent on the Tool and User Frames.  The operator will supply these values directly by 

inputting them or via by measuring them and recording points to define the location and orientation of the work piece or 

space.  

Types of Frames 

World Frames: Default Frame used to describe the location and orientation of the Tool Center Point (TCP). Origin Location of 

TCP is the center of the Tool Plate (No End Effector Attached) and the Robot IS located on the Centerline of J1 Axis and the 

intersection of J2 Vertical Centerline.  World Frame is not editable by the user.  

 

 

  

 

 

 

 

 

Example: Location of the end to a 

robot gripper in relation to the Origin 
Example: Orientation of a robot 

gripper in relation to the Origin. 

Direction it is pointing in 

Example: Planes in relation to Origin 



Tool Frame: Describes the orientation of the physical tool.  Operator can set a tool offset length for the tip of the end 

effector.  By default the Tool Frame is set to the Tool Center Point (TCP) Plate. This makes the work easier since the 

coordinate values in relation to World is set to the tip of the tooling and not the Tool Plate 

                                           

 

 Multiple ways of capturing tool point: Direct Entry, 2-Point, 3-Point, 6-Point (XY), 6-Point (XZ)  

User Frames: Allows the operator to setup a new origin of any location and orientation.  This makes it easier to for the 

operator to check distances based on an object, fixture, or jig and not the World Frame Coordinate System that is based on 

the Robotic Arm.   

Note: if no User Frame is declared then default User Frame will be World Frame 

 

Jog Frames: Allows the user to setup directional movements along a part when the orientation of the part differs from the 

World Frame 

 

Cell Frames: Advanced setup for large workcells that incorporate the Robot and one or multiple machining/handling 

operations. 

 

 

 

 

 

 

 

 

 

 

NOTE: Z-Value is the length of the tooling NOTE: P (pitch) Value set to 

angle Location 



Part Creation and Import  
    Following Steps will have user import a CAD File and Create a Cube to setup a User Frame around their location 

1. Class Website > Industrial Robotics Webpage > Frames: Users > Download Fanuc_User_Frame_Part 

a. Open Download File > Open .zip File >   

 
b. Copy/Cut File > Navigate to Users MyWorkcell Folder > Open User Workcell > Object Folder > Paste File 

 

 
 

2. Open Roboguide 

3. Select Cell > Add Part > Single CAD File 

 

4. Navigate to where the file is saved: This PC > Windows (C:) > My Work Cells > BHS Fanuc Robotic Arm Workcell 

“Student Last Name” > Folder object > Select File > Select Open 

5. Optimization Choice: Quality of the Import Model and if edges can be used in detecton > Select Normal Quality > 

Select Ok 

 

6. Hide Part Rack (See Tutorial Adding Objects to Hide Part Rack) 

7. Attach Part to the Table (See Tutorial Adding Objects to Hide Part Rack) 

8. Adjust Part Location based on the table to the following values 

 



9. Create Box 

a. Select Cell > Add Part > Box 

 
 

b. Set the settings as follows 

 
 

c. Hide Part Rack (See Tutorial Adding Objects to Hide Part Rack) 

d. Attach Part to the Table (See Tutorial Adding Objects to Hide Part Rack) 

e. Adjust Part Location based on the table to the following values 

 
 

10. Robot Default Orientation: Run the Zero 90 Program 

11. Work Cell Looks as Follows 

 

 

 

 



User Frames: Allow the user to set an orientation and location of the origin of the work space 

Options to set User Frame: 

Option 1: 3 Point: Operator Sets the Origin Point > Set X Direction > Set Y Direction 

Option 2: 4 Points: Operator Sets the Origin Point > Set X Direction > Set Y Direction > Set Z Direction 

3 Point Method Setup 

1. Select Hardkey MENU 

 
 

2. Arrow Down to Six > Right Arrow Over > Arrow Down to Option 5 FRAMES > Select Hardkey ENTER 

 

 

 
 

3. Change to User Frame: Select Softkey [OTHER] or Hardkey F3 > Select Option 3 User Frame > Keep Cursor on User 

Frame 1 

NOTE: When a User Frame is not declared in the program or one is declared but not set to specific coordinates the 

robot will default to World Frame 

                 

 

 

 

 

Select Hardkey MENU 

TOOL FRAME Menu is Default 



4. Choose User Frame: Select Softkey DETAIL or Hardkey F2 > Select Sofkey [METHOD] or Hardkey F2 > Change 1. 

Comment > Press Hardkey Enter > Arrow down to Options/Keybd > Select Hardkey Enter > Select Softkey Keyboard 

or Hardkey F5 > Change Name to Rectangle_Block  

 

                      
 

5.  Choosing User Frame Method: Select Softkey [METHOD] or Hardkey F2 >  Select Opton 1: Three Point    

                                                                

            
 

6. Recording Points:  

a. Three Points will be measured to locate a new origin 

i. Point 1: Orient Origin Point 

ii. Point 2: User Defined X Direction Point 

iii. Point 3: User Defined Y Direction Point 

NOTE: Coordinates X and Y do not need to go in the tradition direction of a standard graph (i.e. X being left to 

right and Y being forward and backward), but defined to the users fixture, part, etc. in relation to the 

robot 

 

b. Green Rectangle Box User Frame Points 

                    
 

 

 

 

 

 

 

Orient Origin Point 

Y Direction 

X Direction 

Orient Origin Point 

Y 

Direction 

X  Direction 

Current Frame Data 

In Relation to World 

Frame 

NOTE: All Values are 

in millimeters (mm) 



c. Point 1: Orient Origin Point 

This point will define the distance/angle from World Frame for the Robot.  All coordinate and orientation 

values will factor in the offsets distance/angle from World Frame 

i. On the Teach Pendent: Arrow down to Orient Origin Point 

ii. Jog the Robot Gripper Perpendicular to the Orient Origin Defined Above (Maintain a minimum 

height of about 1” above the block. 

               
iii. Highlight Orient Origin Point > Hold Hardkey SELECT + Softkey RECORD or Hardkey F5 

                

d. Move Back to Origin Point 

i. Highlight Orient Origin Point after it is Recorded 

ii. Hold Deadman Middle + SHIFT + Press Softkey MOVE_TO or Hardkey F4 

 
e. Point 2: X Direction Point 

i. On the Teach Pendent: Arrow down to Orient Origin Point 

ii. Jog the Robot Gripper Perpendicular to the Corner Marked X – Direction  (Maintain a minimum 

height of about 1” above the block. 

            
 

 

Orient Origin Point 

X Direction 

Jog to this Corner 

Orient Origin Point 

Hold SHIFT  

     +  

Press Softkey RECORD 

or Hardkey F5 

Teach Pendent will Confirm Point is Recorded. 

NOTE: Points can be Recorded at any time by going 

through the same process 



iii. Highlight X Direction Point Hold Hardkey SELECT + Softkey RECORD or Hardkey F5 

          
 

f. Point 3: Y Direction Point 

i. On the Teach Pendent: Arrow down to Orient Origin Point 

ii. Jog the Robot Gripper Perpendicular to the Corner Marked Y Direction  (Maintain a minimum height 

of about 1” above the block. 

        
 

iii. Highlight Y Direction Point > Hold Hardkey SELECT + Softkey RECORD or Hardkey F5 

                                              

 

 

 

 

 

 

Orient Origin Point 

Y Direction 

Jog to this Corner 

Hold SHIFT  

     +  

Press Softkey RECORD or 

Hardkey F5 

Teach Pendent will Confirm Point is Recorded. 

NOTE: Points can be Recorded at any time by going 

through the same process 

Hold SHIFT  

     +  

Press Softkey RECORD or 

Hardkey F5 

Teach Pendent will Confirm Point is Recorded. 

NOTE: Points can be Recorded at any time by going 

through the same process 



g. Frame Data Calculated in relation to World Frame 

NOTE: Values may vary slightly based on how close in X, Y and Z the operator got the points on the box 

Operator can now roughly measure back to World Frame Origin (Intersection of J1 and J2) to see if the 

values make sense 

 

 
7. Test User Frame 

a. Set User Frame: Hold Hardkey SHIFT + Press Hardkey COORD 

 

 
 

b. Arrow down to User > Press Harkey #1 to set the User Frame to 1 

 

                

 

  

8. Jog in User Frame Setting 

a. Repeatly Select Hardkey COORD until USER Jog appears 

 

 
 

 

Arrow down to User > Press 

Hardkey #1 to set User Frame  
Check to See User Frame Selection 

Hold Hardkey Shift 

 + 

Select Hardkey COORD 



b. Select Hardkey POSN > Select Sofkey USER or Hardkey F3 

 

                                                                    
 

c. Jog in Frame: X, Y and Z 

i. Check 

1. Make sure the Coordinates and Angles Behave has expected 

2. Check Z+ and Z- to ensure it is moving in the desired manner 

3. Rotate around the joints to notice change in W,P,R based on the origin of User Frame 1 

ii. Move the Robot to Point 1 Origin > Check to see if points match up closely to 0,0,0 

iii. Move the Robot to Point 2 X Direction > Check to see if points match up closely to 200,0,0 

iv. Move the Robot to Point 3 Y Direction > Check to see if points match up closely to 0,200,0 

Submission: Take picture or Screenshot of the POSN Screen at each Location for Use Frame 1 and User Frame 2 

                        Use Virtual Teach Pendent to Show Screens 

                         Steps to Use Virtual Teach Pendent 

1. Teach Pendent MUST BE TURNED OFF (If the Teach Pendent was Turned on with the 

Workcell: Before Proceeding to Step 2: Turn OFF the Teach Pendent > Save Workcell ) 

2. Roboguide: Select Drop Down Menu Robot > Select Teach Pendent > Teach Pendent will 

Load 

NOTE: Virtual Teach Pendent will Open with the Last Active Screen from the Real World Teach 

Pendent or the Virtual Teach Pendent 

 

   

 

 

  

 

3. Using the Mouse Click on the Buttons to Navigate through the Menus (NOTE: Certain Keys 

(i.e. SHIFT, JOINT/Coordinate keys) when selected will stay selected until the user deselects 

them) 

4. Use Windows Snipping Tool to take Screenshots of the POSN Screen > Paste Screenshot into 

a Word Document > Email Document to Teacher 

 

2. Select Hardkey POSN 

1. Select Softkey USER 

or Hardkey F3 

 



Assignment 1: Set User Frame 2: Angle Block 

a. Rename UFrame 2 to Angle_Block 

b. Set the orientation with the gripper Pointing at the angled surface record the Origin, X Direction and Y Direction 

as Shown.  DO NOT Intersect the Part 

c. Test: Set User Frame Hardkey SHIFT + Hardkey COORD > Arrow to User Frame > Select Hardkey #2 to set User 

Frame > Jog in Frame > Check Values 

 
9. Test User Frame 

a. Set User Frame: Hold Harkey SHIFT + Press Hardkey COORD 

 
 

 

 

b. Arrow down to User > Press Harkey #1 to set the User Frame to 1 

 

                 

 

  

 

Origin 

Y Direction 

X Direction 

Arrow down to User > Press 

Hardkey #2 to set User Frame  
Check to See User Frame Selection 

 



10. Jog in User Frame Setting 

a. Repeatly Select Hardkey COORD until USER Jog appears 

 

 
 

b. Select Hardkey POSN > Select Sofkey USER or Hardkey F3 

 

                                                                    
 

c. Jog in Frame: X, Y and Z 

i. Check 

1. Make sure the Coordinates and Angles Behave has expected 

2. Check Z+ and Z- to ensure it is moving in the desired manner 

3. Rotate around the joints to notice change in W,P,R based on the origin of User Frame 2 

ii. Move the Robot to Point 1 Origin > Check to see if points match up closely to 0,0,0 

iii. Move the Robot to Point 2 X Direction > Check to see if points match up closely to 200,0,0 

iv. Move the Robot to Point 3 Y Direction > Check to see if points match up closely to 0,200,0 

Submission: Take picture or Screenshot of the POSN Screen at each Location 

 

Assignment 2: Create the following Program 

1. Name Program User_Frame_”Student Last Name” 

Optional: Create 4 Separate Programs > Create 1 Main Program and CALL sub-programs into Main Program 

2. Set World Frame (User Frame = 0) 

3. Set Positional Register [1] or Call Program Zero 90 

4. Part 1 of Program 

a. Comment: Trace Rectangle Block + Gripper 

b. Set User Frame to 1 (Rectangle Block) 

c. Set Tool Frame 8 (Gripper) 

d. Trace the Top Surface of the Rectangle: Keep the Gripper Tip Minimum of 2” or 50mm Above the Part 

e. To help getting to the origin point of the block 

i. Select Hardkey Menu > Select Option 6 Setup > Arrow over to Option 5 Frames > Select User 

Frame 1 > Highlight Origin Point > Deadman Middle + Hardkey RESET to Clear Faults > with 

Deadman still held + Hold Hardkey SHIFT + Softkey MOVE_TO or Hardkey F4 

ii. Program Points 

 

 

 

 

 

1. Select Hardkey POSN 

2. Select Softkey USER 

or Hardkey F3 



Assignment 2 Continued 

5. Part 2 of Program 

a. Comment Trace Angle Block + Gripper 

b. Set User Frame to 2 (Angle Block) 

c. NOTE: Tool Frame will be the same as Part 1 so it does not need to be redeclared 

d. Trace the Angle Surface of the Rectangle: Keep the Gripper Tip Minimum of 2” or 50mm Above the Part 

e. To help getting to the origin point of the block 

i. Select Hardkey Menu > Select Option 6 Setup > Arrow over to Option 5 Frames > Select User 

Frame 1 > Highlight Origin Point > Deadman Middle + Hardkey RESET to Clear Faults > with 

Deadman still held + Hold Hardkey SHIFT + Softkey MOVE_TO or Hardkey F4 

ii. Program Points 

6. Part 3 of Program 

a. Comment Trace Angle Block + Vacuum Gripper 

b. Set User Frame to 2 (Angle Block) 

c. Set Tool Frame 1 (Gripper) 

d. Trace the Top Surface Rectangle: Keep the Gripper Tip Minimum of 2” or 50mm Above the Part 

e. To help getting to the origin point of the block 

i. Select Hardkey Menu > Select Option 6 Setup > Arrow over to Option 5 Frames > Select User 

Frame 2 > Highlight Origin Point > Deadman Middle + Hardkey RESET to Clear Faults > with 

Deadman still held + Hold Hardkey SHIFT + Softkey MOVE_TO or Hardkey F4 

ii. Program Points 

7. Part 4 of Program 

a. Comment Trace Angle Block + Vacuum Gripper 

b. Set User Frame to 2 (Angle Block) 

c. NOTE: Tool Frame will be the same as Part 3 so it does not need to be redeclared 

d. Trace the Angle Surface of the Rectangle: Keep the Gripper Tip Minimum of 2” or 50mm Above the Part 

e. To help getting to the origin point of the block 

i. Select Hardkey Menu > Select Option 6 Setup > Arrow over to Option 5 Frames > Select User 

Frame 1 > Highlight Origin Point > Deadman Middle + Hardkey RESET to Clear Faults > with 

Deadman still held + Hold Hardkey SHIFT + Softkey MOVE_TO or Hardkey F4 

ii. Program Points 

8. Set World Frame(User Frame = 0) 

9. Set Tool Frame Gripper 

10. Set Positional Register [1] or Call Program Zero 90 

Run the Program 

Submission: Take a Video of the Program Running or Show the Teacher 

 

 

 

 

 

 

 

 

 



Assignment 3: Move Object > Update User Frame 

1. Move the Angled Block to the Following Coordinates 

a. X = 1100 

b. Y = 300 

 
2. Update User Frame 

a. Select Hardkey MENU > Select Option 6 Setup > Arrow over to Option 5 FRAMES > Arrow to User Frame 2 > 

Select Hardkey ENTER > Arrow down to Orient Origin Point: > Jog Robot to new Origin Point > Hold Shift + 

Softkey RECORD or Hardy F5 

NOTE: X and Y Direction have not changed direction so these points do not need to be updated.    

3. Run Program 

Submission: Take a Video of the Program Running or Show the Teacher 

 


