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Two Kinds of Reports in Genesis

In Genesis, some screens have built-in reports. The first part of this chapter, ‘The Printer
Icon’, describes how to access and print these screen-specific reports. In addition, each
Genesis module has its own extensive set of reports. These are found on a series of
Reports screens. There is one Reports screen for each Genesis module:

Student Data>Reports
Attendance—>Reports
Scheduling>Report

Next Year Scheduling>Reports
Grading~2>Reports
Registration>Reports
Conduct>Reports
Administration>Reports

The operation of the built-in reports differs from the operation of the reports listed on one
of the Reports screens. This chapter is divided into two parts, reflecting the two types of
operation:

1. The Printer Icon — A Screen’s Default Report
2. Genesis Reports Tabs
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The Genesis Printer Icon

On some Genesis screens a small printer icon is visible as the first icon in the set in the
upper right hand corner of the screen. When it is present, the screen has its own built-in
report. When the Printer Icon is not present, the screen has no built-in report.
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Search Reset
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|:| 1008655 ABLAZA,JR LAZIR 2002 F114 11 M ACTIVE !%
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®) Add checked students to this list: | A~Z ¥| (O Add checked students to a new list: ok
2269 Students. ©Copyright Genesis Educational Serviges,Inc. ﬂ
2] 2269 students. P Internet

Figure 1 - student Data>Student List screen illustrating the printer icon
When the printer icon appears, the screen has a built-in report.

To access the built-in report for a screen, click the Genesis printer icon. This causes the
report to be run and the resulting PDF file to be displayed in the browser.

Genesis uses Adobe’s Adobe Reader 6.0 to display and actually print reports. Adobe

Reader 6.0 takes over the browser and displays the report. The user can then use the
Adobe Reader controls to send the report to a printer. This is illustrated below:
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The result of clicking the printer icon on the Student Data—> Student List screen:
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desi red 403807 ADAMS CARL 2002 208 10 M ACTIVE
1008579 ADESHINA SAMUEL 2002 C149 11 M ACTIVE
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Figure 2 - Student Data->Student List report displayed via the Adobe Reader

To Control the Display:
Use the Adobe tabs shown at the left edge of the display are used to page through the
report.

To Print the Report:
a. Click on the “Print” icon shown at the top of the Adobe Reader display. DO
NOT use the browser’s own File>Print menu item.
b. The standard Print Dialog will appear:

NOTE: ADOBE READER has taken over the screen. Genesis has temporarily
given up control.

NOTE: DO NOT USE THE BROWSER File>Print to print the report. ONLY use the
Adobe ‘Print’ icon.
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Figure 3 - The Standard Print Dialog is displayed and user selects the desired printer and clicks ‘OK’

c. The user selects the desired printer from the print dialog and clicks ‘OK’. The
report is printed on the selected printer.
d. To return to Genesis, the click the browser’s BACK button.

NOTE: The Browser BACK Button

When using Genesis, the browser’s own BACK button should ONLY be used to
return to Genesis from printing a report via Adobe Reader. It should never be
used at any other time.
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1. Genesis Report Tabs

A large number of Genesis Reports can be found on the Genesis ‘Reports’ tabs. Every
Genesis Module contains a “Reports” category tab:
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Figure 4 - Student Data->Reports Tab illustrated

View A List of Reports:
To view the list of available reports, click the “reports™ tab. This brings up a screen
listing all the reports available to you in the selected module.
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The Student Data>Reports Tab:
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| List Reports |

Seq Name. Last Run Last Run By
20995 Demographic Data and Address Profiles 2004-10-21 10:21:53.0 mzghd H &8
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20999 District ESL-LEP School Summary Report ]
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21160 Manthly/Yeary Entared Loft Report - Grouped 2004-10-21 14:08:36.0 blazer g8 & a
21170 Monthly/Yearly Left Report = Ungrouped 2004-10-11 10:58:49.0 8 & a
21180 NEXT YEAR oster for All Hom FE) =
=]
SCoeyriaht Gensss Educationsl Servcesne,

&l &P Internet
Figure 5 - Sstudent Data>Reports Tab displayed. Standard Reports screen layout is shown.

The Reports screens list all reports available to the user.

SECURITY NOTE:

Reports listed on a single Reports screen will be different for different users. Access to
reports is controlled by your Genesis Roles. Users are assigned different Roles, thus the
users will be able to see and run different collections of reports.

Layout of Reports Screens

All reports screens have the same layout. There are 7 columns:
The Report Number

The Name of the Report

Last Run Date

User Id of Last User to Run the Report

The ‘Run Report’ icon

The “Display Last Run’ icon

The ‘Report Archive’ icon

NogakowhE
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Report Screen Layout, Cont.
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Figure 6 - Student Data>Reports Tab displayed. Columns are Illustrated.

Running a Report
To run a report listed on a Genesis Reports screen, click the ‘Run Report’ icon in column
5.

There are 5 steps to printing a report:

1. Select the report and click the *‘Run Report’ icon. This brings up the ‘Run
Report’ dialog shown below.

2. Set any necessary parameters for running the report. Some reports have no
parameters and other reports will have as many as 6 or 7 parameters that must be
set.

3. Click the *schedule Report’ button to start the report processing. When
processing is completed, the report is displayed by the Adobe Reader in the center
of the Genesis screen.

4. To actually print the report, click the Adobe Reader ‘Print’ button. This brings up
the standard Windows Printer Dialog

5. Select the desired printer and click ‘ok’. The report prints on the desired printer.
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Initiating a Report — The Report Invocation Screen
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Schedule Report Field —
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Enter Homeroom:

E-Mad & copy of the report? []
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4] oone
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Figure 7 - Reports invocation screen. Fields are illustrated.

Report Invocation Screen
To start running the report, the user must enter all required parameters and click the
‘Schedule Report’ button.

Many reports do not take parameters, the user need only click the *Schedule Report’
button to start running the report.

Sending the Report as Email to Oneself

If email is set up for Genesis, the user can click the ‘E-mail a copy of the report’
checkbox and a copy of the report PDF file will be sent to the user’s email address.
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Waiting for a Report to Complete
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©Cugyrialt Genesis Educations! Services,inc,

4] pane P internet
Figure 8 — Report is Running screen. Fields are illustrated.

Waiting for the Report
This screen is displayed if you choose to wait for the report to complete.

NOTE: You DO NOT have to wait for the report to complete. The report will run to
completion whether or not you stay on this page and wait. You can then use the “View
Last’ icon to bring up the completed report.

The fields in the display include:

Status — is the report running or ‘queued’ waiting to run

Message — the Report software can send updates to let you know how it is progressing.
Queued On - time when the report was initiated

It’s Now — Current time. This shows how long the report has been running.

Name — Name of report

Description — Description of the report

E-Mail Report — indicates if the report output will be emailed or not.
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Displaying and Printing the Finished Report

Genesis displays the completed report in the central frame:
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Figure 9 — Report display. Adobe Reader controls the center portion of the screen to display the report

Viewing and Printing the Report

Genesis exclusively uses Adobe Reader 6.0 to display the finished report. This allows
the report to be viewed before it is printed: many reports can be discarded without ever
being printed, saving paper and money.

Printing the Report

To print the report, click the ‘Print” button at the top left of the Adobe Reader frame. DO
NOT use the browser’s own File>Print menu item, it does not work correctly to print
the report.

Clicking the Adobe Print icon brings up the standard Windows Print Dialog.
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Printing the Report, Cont.

Frinter
NSO | CE\//OLFHP Ofice Jet Rl v Properties
Status:  Ready [ Printto file

Type: HF Office Jet R80xi

Print Range Prewiew
@Al
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() Current page
() Pages from: |1 to [1 12 | =

Subset :AII pagesinrange b ||:| Fewverse pages

11

T
bt

Page Handling

——r

Copies: | s ! 85
Fage Scaling: |Fitto paper VJ
Auto-Fotate and Center
e
[ ] Choose Paper Source by PDF page size
FrintWwhat: |Ducument | )
— Units: Inches Zoom: 34%
[ Frinting Tips l l Advanced ] l Ok l \ Cancel l

Figure 10 — standard Windows Print Dialog.

The standard Windows Print dialog allows you to select any printer available to you and
to control the printing of the document in the usual way.

NOTE: This is not controlled by Genesis — This is a standard Windows Service.

Click ‘OK’ to print the Report or ‘Cancel’ to return to the Report Display screen.
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Returning to Genesis from the Report Display Screen

Q-0 MG LPe-SELUAH 9S8 or-c-
GE”ES{S School vear: |2004-05 % SENESINSEbnotIteTcE FE-TNHIEFETEE | ™ B

— e Tuor - GanndsM;an
GENESIS High School ¥ How Do L... Choose... (» Inbox (0)

SRR | Ragistration Scheduling Next Year Scheduling | “=+ding | Attendante | Calendar  Transcript

Student List_ Edit Lists _ Labels _ Set Next School & Graflg [ Reports | )N Testing
Student Data.Student List S

I SevenCopy i Print @ Email @) Search || <) | T8 Select Texat - fi) | @ - 7 | ®%% - @|r s o k|
-+

g 44+ CENEATN STUDENT DATA REPORTING EUN-SYSTEM +o
11713/ 3004 MOIEROON BOETER EEFORT
TENESIS High School
g

I—

sTupENT o sams GEX AGE GE MR PARENT/GUARDIAN rrREET crrr & se  puoue
= wsaTL BEMADUCE, AOEUR L Wo18 1L 102 BAKEETT, hOT 51 WOOULAKE DR ToMS RIVER wa o owT T2} fl 24/
‘g' 1007468 FIRNFAN, FAITLIN ELIZAEETH F IS 03 103  ANDERSON, FATHLERM 361 VAIL AVE ToMz RIVER BI TSI (30E1-S1.0848  05/13/1385
- FIEIARICES, VERA RAY ¥ o1 oo 103 L, wiLLIaW 340 VERRINE AVE Toms mivER na oam o/
" 105453 FLATONYCHEY, MEREY W15 10 103 RUIT-MALCOLM, MILDSED 158 HANCOCY BD ToMZ RIVER w1 cer 02/23/ 1985
% 05470 EMYTH, PACRAEL CAVALIERE Pl 0 103 VIR, JAIME 100 KILMER CT ToME RIVER nI_cats 04/87/ 1980
. Studentn do BR: s
m
@

| 11%8.5in

1of 112 P okl

& Comyriaht Geness Educations! Servcesine,

8] P Intermet
Figure 11 — Report Display. Click any tab to move out of this screen.

NOTE: DO NOT USE the browser BACK button to leave this screen. Genesis is
still in control of the screen — note the Genesis tabs. To leave this screen, simply click a
different Genesis tab.

Returning to the Reports Screen
To return to the Reports screen to select a new report, click the “reports” tab.
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Scheduling a Report for Later Execution

Reports need not be run immediately: they can be scheduled for a later time and or later

date.
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both date and time fields. Clicking
the calendar icon brings up a
calendar to allow you to select a
date.
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Figure 12 - Reports invocation screen with ‘Schedule Run’ fields showing

Do Not Run Report Immediately: Schedule for Later

1. Uncheck the ‘Run Immediately’ checkbox. This causes the Schedule Report
fields to appear.

2. Setthe Run Date. The date DOES NOT automatically defaults to “today”. The
user must select the run date.

3. Select the time to run the report. The ‘am/pm’ drop down is used to select AM or
PM.

4. Click the ‘schedule Reports’ button to schedule the report. The report will run at
the appointed date and time.
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Retrieving the Last Run of a Report
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How Do L... Choose... (» I 0

L ERVE R Ragistration Scheduling Next Year Scheduling | Grading | attendance | Calendar  Transcript Selup
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Student Data.Student List

[ ustreports [0
P A~

Seq Name Last Run Last Run By
20995  Demographic Data and Address Profiles 2004- 10 aales ma)

20997 Distnct ESL-LEP Report 2004-10-25 09:53:10.0 blazer
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21060 Homercom Register Check for 1 Homercom 2004-10-22 15:55:28.0 class
21070 Homercom Register Check for all Homerooms 2004-10-11 10:56:46.0 blazer
210860 Homearcom Roster for 1 Homercom 2004-10-25 17:26:52.0

21090 Homercoem Roster for All HRs with Bus Info 2004-10-22 15:56:33

21100 Homereem Roster for All Homerocoms
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21120 Homaroom Roster with Teacher & Bus Info

T T AT last run of the report. The ‘Last
21130 Homareom Roster with Teacher for all Homarooms Run Date, and [13 LaSt Run byn

21150 HOMBroom Summary List
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Figure 13 - Reports screen illustrating the ‘Last Run’ icon column

Viewing the Most Recent Run of a Report
1. Select a rReports tab to bring up a Reports screen.
2. Identify the report you wish to view.
3. Click the middle icon, the ‘View Last Run’ icon. This causes the most recent run
of the report to be loaded into the browser under the control of the Adobe Reader
(See above).

Report Archives

Most reports only save the most recent run. However, some reports retain all previous
runs. These can be found on the Reports>Archive screen and are accessed via the
‘Archive’ icon.
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Archived Reports

Certain reports are set to save all their runs. The Reports—=> Archive screen is used to

view the list of archived runs for a single report.
0-0 HRAG AL LEE 298
66”6515 GENESIS School District FR-HIEETER B S B

School Year: |2004-05 v m : SEgH Py
GENESIS High School v How Do 1.. [choose... (B I:;Dis(u;) minis

Student Data 'Reqi;tralinn Scheduling |Next Year Scheduling | Grading | Attendance | Calendar 'Tranmript Setup Next p

Student List Edit Lists Labels Set Next Scheel & Grade | Reports | NI Testing
Student Data.Student List v

f T [ Archive W )
Homeroom Roster for All HRs with Bus gchws /\ /\
0]
] )

Completed On Engine Message

11/12/2004 11:56 AM Success
09/05/2004 02:35 PM Success

09/05/2004 02:37 PM Success

Note: Archive tab . .
Display icons

Delete icons
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Figure 14 — Reports>Archive screen for a report with multiple runs archived

Information on Each Run
- Run date and time
- User Id of user who ran report
- Success or failure message

Bringing Up an Archived Run of a Report
1. Select the desired report
2. Click on the “Display’ icon. This loads the report into Adobe Reader.

Deleting a Single Run:
1. Select the desired report
2. Click on the ‘Delete icon’. This removes the run from the list and the archive.

To Return to Report List:
Click the reports tab.
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HOW DO 1?

Print a Genesis Report?

1.

2
3
4
5.
6.
-
8
9
1

Click on a Reports tab (Student Data>Reports, Attendance>Reports,
Grading2>Reports, Scheduling>Reports, Conduct%ReportS,...).

Locate the report you wish to run.

Click on the ‘Run Report’ icon

Enter any needed parameters

Click on ‘schedule’

Wait for the report to complete. Some reports can take up to 15 minutes.
Click on the Adobe Reader ‘Print’ icon

Select your desired printer.

Click ‘ok’

0. Click any Genesis tab to move to a new function.

Retrieve and Print the Last Run of a Report?

1.

N~ WN

Click on a Reports tab (Student Data>Reports, Attendance>Reports,
Grading>Reports, Scheduling>Reports, ConductéReports,...).

Locate the report you wish to print.

Click on the ‘Last Report’ icoOn

Wait for the report to load

Click on the Adobe Reader ‘print’ icon

Select your desired printer.

Click ‘oK’

Click any Genesis tab to move to a new function.

Print the Genesis Report for the Current Screen?

1.

Nogakown

Locate the Genesis printer icon, first in the series of icons at the upper right
corner of the screen. If there is no printer icon, there is no report for this
screen.

Click the printer icon

Wait for the report to complete

Click on the Adobe Reader “print’ icon

Select your desired printer.

Click ‘oK’

Click the browser’s own ‘Back’ button to return to Genesis

Schedule a Report to Run Later?

1.

Nogabkown

Click on a Reports tab (Student Data>Reports, Attendance>Reports,
Grading=2>Reports, Scheduling>Reports, Conduct—)Reports,...).

Locate the report you wish to run.

Click on the ‘Run Report’ icon

Enter any needed parameters

Uncheck the ‘Run Immediately’ check box

Select a run date and time.

Click ‘schedule’
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8.
9.

Click ‘OK’ to the “‘Report has been scheduled’ popup.
After report has been run, print the archived report.

Print an Archived Report?

1.

BOO~NOUOR~WN

0.

Click on a Reports tab (Student Data>Reports, Attendance>Reports,
Grading2>Reports, Scheduling>Reports, ConductéReports,...).

Locate the report you wish to print.

Click on the ‘Archived Reports’ icon (right-most icon)

Select the version of the report to print

Click on the ‘view Report’ icon (left-most icon) for the selected report
Wait for the report to load

Click on the Adobe Reader ‘print’ icon

Select your desired printer.

Click ‘ok’

Click the browser’s own ‘Back’ button to return to Genesis

Delete a Report from the Archive?

1.

NG WN

Click on a Reports tab (Student Data>Reports, Attendance->Reports,
Grading2>Reports, Scheduling>Reports, Conduct%ReportS,...).

Locate the report you wish to print.

Click on the ‘Archived Reports’ icon (right-most icon)

Select the version of the report to delete

Click on the “Delete Report’ icon (right-most icon) for the selected report
Click ‘ok’ to the “Are you sure you want to delete this report?” popup
Click ‘ok’ to the “Report successfully deleted.t”” popup

Click the browser’s own ‘Back’ button to return to Genesis

Find Out Who Last Ran a Report?

1.

w

Click on a Reports tab (Student Data>Reports, Attendance>Reports,
Grading=2>Reports, Scheduling>Reports, Conduct—)Reports,...).

Locate the report you wish to check on.

Locate the ‘Last Run By’ column

Read the user id of the person to last run the selected report.
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